From 2:10 PM to 2:35 PM EDT, platform connectivity was disrupted across all environments.
This outage resulted from an unexpected service shutdown during a rolling server cluster upgrade. Specifically, the service failed to reassign to other instances before the final server update. We are updating our documentation to include more rigorous validation steps to prevent future occurrences. We apologize for the disruption.
Posted Mar 25, 2025 - 15:53 EDT
Monitoring
The issue has been resolved, and services are now operating normally.
We are actively monitoring the platform and will provide a root cause analysis shortly.
Posted Mar 25, 2025 - 14:39 EDT
Investigating
We are currently investigating a problem with our integration platform.
It is currently not possible to connect to the platform and integration processes are affected. We will provide more information shortly.
Posted Mar 25, 2025 - 14:15 EDT
This incident affected: thecloudconnectors.io (Integration Platform, Packages Management, Learn Platform, SFTP Service) and Management (Deployments, Worker Resources).